Synchronet now requires the libarchive development package (e.g. libarchive-dev on Debian-based Linux distros, libarchive.org for more info) to build successfully.

Commit 03b7b2f9 authored by Rob Swindell's avatar Rob Swindell 💬

Fix socket descriptor leak in fastcgi_connect()

Found by Coverity-scan (CID 330051)

@Deuce should review this.
parent 7257b432
Pipeline #1815 passed with stage
in 11 minutes and 25 seconds
......@@ -3818,6 +3818,8 @@ static SOCKET fastcgi_connect(const char *orig_path, SOCKET client_sock)
if((ERROR_VALUE==EWOULDBLOCK || ERROR_VALUE==EINPROGRESS)) {
if (socket_writable(sock, 1000 /* TODO: Make configurable! */))
result=0; /* success */
else
closesocket(sock);
}
else
closesocket(sock);
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment