Synchronet now requires the libarchive development package (e.g. libarchive-dev on Debian-based Linux distros, libarchive.org for more info) to build successfully.

Commit 08cd3e50 authored by echicken's avatar echicken 🐔

Return-style load of lib/auth.js.

Maybe I should just start using require() all over the place.
parent dd531e80
......@@ -6,8 +6,8 @@
load('modopts.js');
var settings = get_mod_options('web');
load(settings.web_directory + '/lib/init.js');
load(settings.web_lib + 'auth.js');
load(settings.web_lib + 'init.js');
const auth_lib = load({}, settings.web_lib + 'auth.js');
load(settings.web_lib + 'forum.js');
var reply = {};
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment