Synchronet now requires the libarchive development package (e.g. libarchive-dev on Debian-based Linux distros, libarchive.org for more info) to build successfully.

Commit 1111fb24 authored by Rob Swindell's avatar Rob Swindell 💬

Allow SAFECAT to work on uchar arrays

Caught by CID 331001

The use of SAFECAT() with a typecast to a pointer is not going to work as expected. This change broke line-based telnet-gateway functionality (unconfirmed, but pretty obvious).
parent a1f9abb7
Pipeline #1851 failed with stage
in 9 minutes and 11 seconds