Synchronet now requires the libarchive development package (e.g. libarchive-dev on Debian-based Linux distros, libarchive.org for more info) to build successfully.

Commit 45b3170d authored by echicken's avatar echicken 🐔

Yuck.

parent 6623cff0
......@@ -6,13 +6,18 @@ function cycle() {
if (time() - last_run <= frequency) return;
last_run = time();
const tg = system.get_telegram(user.number);
if (tg !== null) emit({ event: 'telegram'
, data: JSON.stringify(html_encode(tg.replace('\7', '').replace(/\1./g, '')
, /* ex-ascii */true
, /* white-space */false
, /* ansi */false
, /* ctrl_a */false))
if (tg !== null) {
emit({
event: 'telegram',
data: JSON.stringify(html_encode(
tg.replace('\7', '').replace(/\1./g, ''),
/* ex-ascii */true,
/* white-space */false,
/* ansi */false,
/* ctrl_a */false
));
});
}
}
this;
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment