Synchronet now requires the libarchive development package (e.g. libarchive-dev on Debian-based Linux distros, libarchive.org for more info) to build successfully.

Commit bd566b77 authored by Rob Swindell's avatar Rob Swindell 💬

Address GCC warnings recently introduced by not defining bbs_options in jsexec

parent eb079918
Pipeline #1431 passed with stage
in 9 minutes and 59 seconds
......@@ -29,7 +29,7 @@
#include <termios.h>
#endif
#define STARTUP_INI_BITDESC_TABLES
#define STARTUP_INI_JSOPT_BITDESC_TABLE
#include "sbbs.h"
#include "ciolib.h"
#include "ini_file.h"
......
......@@ -212,6 +212,13 @@ static ini_bitdesc_t bbs_options[] = {
{ 0 ,NULL }
};
#ifndef STARTUP_INI_JSOPT_BITDESC_TABLE
#define STARTUP_INI_JSOPT_BITDESC_TABLE
#endif
#endif
#ifdef STARTUP_INI_JSOPT_BITDESC_TABLE
static ini_bitdesc_t js_options[] = {
{ 1<<0 ,"STRICT" },
......@@ -224,10 +231,9 @@ static ini_bitdesc_t js_options[] = {
{ 1<<14 ,"METHODJIT" },
{ 1<<15 ,"PROFILING" },
{ 1<<16 ,"METHODJIT_ALWAYS" },
/* terminator */
/* terminator */
{ 0 ,NULL }
};
#endif
#ifdef __cplusplus
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment