Synchronet now requires the libarchive development package (e.g. libarchive-dev on Debian-based Linux distros, libarchive.org for more info) to build successfully.

Commit ff4d1a08 authored by rswindell's avatar rswindell

malloc.h is no longer #included for any flavor of Unix (not just BSD).

parent 4d7cfa68
......@@ -52,7 +52,7 @@
#ifndef VTOOLSD
/* FreeBSD uses <stdlib.h> instead of <malloc.h> */
#ifdef __FreeBSD__
#ifdef __unix__
#include <stdlib.h>
#else
#include <malloc.h> /* malloc prototype */
......
......@@ -86,7 +86,7 @@
#include <stdlib.h>
#include <string.h>
#ifndef __FreeBSD__
#ifndef __unix__
#include <malloc.h>
......
......@@ -55,7 +55,7 @@
#include <mem.h>
#endif
#ifndef __FreeBSD__
#ifndef __unix__
#include <malloc.h>
#endif
......
......@@ -49,7 +49,7 @@
/* ANSI C Library headers */
#ifndef __FreeBSD__
#ifndef __unix__
#include <malloc.h>
#endif
......
......@@ -37,7 +37,7 @@
/* ANSI */
#ifdef __FreeBSD__
#ifdef __unix__
#include <stdlib.h> /* malloc/realloc/free is defined here */
#else
#include <malloc.h>
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment