Synchronet now requires the libarchive development package (e.g. libarchive-dev on Debian-based Linux distros, libarchive.org for more info) to build successfully.

Commits (1)
...@@ -78,7 +78,7 @@ diff -ur ../cl-old/io/tcp_rw.c ./io/tcp_rw.c ...@@ -78,7 +78,7 @@ diff -ur ../cl-old/io/tcp_rw.c ./io/tcp_rw.c
+#ifdef __WINDOWS__ +#ifdef __WINDOWS__
if( FD_ISSET( netStream->netSocket, &exceptfds ) ) if( FD_ISSET( netStream->netSocket, &exceptfds ) )
+#else +#else
+ if (fds.revents | (POLLERR | POLLNVAL)) + if (fds.revents & (POLLERR | POLLNVAL))
+#endif +#endif
{ {
int socketErrorCode; int socketErrorCode;
...@@ -105,4 +105,3 @@ diff -ur ../cl-old/io/tcp_rw.c ./io/tcp_rw.c ...@@ -105,4 +105,3 @@ diff -ur ../cl-old/io/tcp_rw.c ./io/tcp_rw.c
return( CRYPT_OK ); return( CRYPT_OK );
} }
Only in ./tools: endian