Synchronet now requires the libarchive development package (e.g. libarchive-dev on Debian-based Linux distros, libarchive.org for more info) to build successfully.

...
 
Commits (1)
...@@ -6,13 +6,18 @@ function cycle() { ...@@ -6,13 +6,18 @@ function cycle() {
if (time() - last_run <= frequency) return; if (time() - last_run <= frequency) return;
last_run = time(); last_run = time();
const tg = system.get_telegram(user.number); const tg = system.get_telegram(user.number);
if (tg !== null) emit({ event: 'telegram' if (tg !== null) {
, data: JSON.stringify(html_encode(tg.replace('\7', '').replace(/\1./g, '') emit({
, /* ex-ascii */true event: 'telegram',
, /* white-space */false data: JSON.stringify(html_encode(
, /* ansi */false tg.replace('\7', '').replace(/\1./g, ''),
, /* ctrl_a */false)) /* ex-ascii */true,
/* white-space */false,
/* ansi */false,
/* ctrl_a */false
));
}); });
}
} }
this; this;