Synchronet now requires the libarchive development package (e.g. libarchive-dev on Debian-based Linux distros, libarchive.org for more info) to build successfully.

Commits (1)
......@@ -506,7 +506,7 @@ int conn_socket_connect(struct bbslist *bbs)
case EWOULDBLOCK:
#endif
for(;sock!=INVALID_SOCKET;) {
if (socket_readable(sock, 1000)) {
if (socket_writable(sock, 1000)) {
if (socket_recvdone(sock, 0)) {
closesocket(sock);
sock=INVALID_SOCKET;
......