Synchronet now requires the libarchive development package (e.g. libarchive-dev on Debian-based Linux distros, libarchive.org for more info) to build successfully.

git diff not very informative; I think I removed some trailing whitespace. You're welcome.

14 jobs for xjs-forum in 14 minutes and 1 second (queued for 14 seconds)
latest
Status Job ID Name Coverage
  Build
failed #19190
FreeBSD
jsdoor-freebsd

00:00:13

passed #19191
Linux
jsdoor-linux

00:10:30

passed #19193
FreeBSD
jsdoor-windows

00:02:35

failed #19185
FreeBSD
sbbs-freebsd

00:00:17

passed #19180
Linux
sbbs-linux

00:13:54

passed #19183
Windows
sbbs-windows

00:05:26

passed #19192
FreeBSD
sexpots-freebsd

00:00:26

passed #19181
Linux
sexpots-linux

00:00:26

passed #19184
Windows
sexpots-windows

00:00:30

passed #19188
FreeBSD
syncdraw-freebsd

00:00:33

passed #19189
Linux
syncdraw-linux

00:00:37

passed #19186
FreeBSD
syncterm-freebsd

00:01:28

passed #19182
Linux
syncterm-linux

00:04:48

passed #19187
FreeBSD
syncterm-windows

00:02:28

 
Name Stage Failure
failed
jsdoor-freebsd Build
checking whether the compiler supports -Werror=return-type... yes
checking whether ld has archive extraction flags... yes
checking that static assertion macros used in autoconf tests work... yes
checking for 64-bit OS... yes
checking for Python version >= 2.5 but not 3.x... configure: error: Python 2.5 or higher (but not Python 3.x) is required.
gmake[1]: *** [GNUmakefile:74: ../build/../../src/../3rdp/clang.freebsd.amd64.release/mozjs/lib/libmozjs185-1.0.a] Error 1
gmake[1]: Leaving directory '/var/tmp/gitlab_runner/builds/TkL89aUh/5/main/sbbs/3rdp/build'
gmake: *** [/var/tmp/gitlab_runner/builds/TkL89aUh/5/main/sbbs/src/sbbs3/../build/Common.gmake:521: js] Error 2
ERROR: Job failed: exit status 1
failed
sbbs-freebsd Build
checking whether the compiler supports -Werror=return-type... yes
checking whether ld has archive extraction flags... yes
checking that static assertion macros used in autoconf tests work... yes
checking for 64-bit OS... yes
checking for Python version >= 2.5 but not 3.x... configure: error: Python 2.5 or higher (but not Python 3.x) is required.
gmake[1]: *** [GNUmakefile:74: ../build/../../src/../3rdp/clang.freebsd.amd64.release/mozjs/lib/libmozjs185-1.0.a] Error 1
gmake[1]: Leaving directory '/var/tmp/gitlab_runner/builds/TkL89aUh/2/main/sbbs/3rdp/build'
gmake: *** [/var/tmp/gitlab_runner/builds/TkL89aUh/2/main/sbbs/src/sbbs3/../build/Common.gmake:521: js] Error 2
ERROR: Job failed: exit status 1