Synchronet now requires the libarchive development package (e.g. libarchive-dev on Debian-based Linux distros, libarchive.org for more info) to build successfully.

Resolve some GCC warnings about uncheck return values from std C functions

write()
chsize()
14 jobs for new_file_base in 8 minutes and 59 seconds (queued for 9 seconds)
latest
Status Job ID Name Coverage
  Build
failed #26736
FreeBSD
jsdoor-freebsd

00:00:38

passed #26737
Linux
jsdoor-linux

00:06:01

passed #26739
FreeBSD
jsdoor-windows

00:02:35

failed #26731
FreeBSD
sbbs-freebsd

00:00:45

passed #26726
Linux
sbbs-linux

00:08:56

passed #26729
Windows
sbbs-windows

00:05:37

passed #26738
FreeBSD
sexpots-freebsd

00:00:42

passed #26727
Linux
sexpots-linux

00:00:23

passed #26730
Windows
sexpots-windows

00:00:37

passed #26734
FreeBSD
syncdraw-freebsd

00:01:03

passed #26735
Linux
syncdraw-linux

00:00:55

passed #26732
FreeBSD
syncterm-freebsd

00:01:58

passed #26728
Linux
syncterm-linux

00:02:44

passed #26733
FreeBSD
syncterm-windows

00:02:58

 
Name Stage Failure
failed
sbbs-freebsd Build
checking whether the compiler supports -Werror=return-type... yes
checking whether ld has archive extraction flags... yes
checking that static assertion macros used in autoconf tests work... yes
checking for 64-bit OS... yes
checking for Python version >= 2.5 but not 3.x... configure: error: Python 2.5 or higher (but not Python 3.x) is required.
gmake[1]: *** [GNUmakefile:74: ../build/../../src/../3rdp/clang.freebsd.amd64.release/mozjs/lib/libmozjs185-1.0.a] Error 1
gmake[1]: Leaving directory '/var/tmp/gitlab_runner/builds/TkL89aUh/1/main/sbbs/3rdp/build'
gmake: *** [/var/tmp/gitlab_runner/builds/TkL89aUh/1/main/sbbs/src/sbbs3/../build/Common.gmake:521: js] Error 2
ERROR: Job failed: exit status 1
failed
jsdoor-freebsd Build
checking whether the compiler supports -Werror=return-type... yes
checking whether ld has archive extraction flags... yes
checking that static assertion macros used in autoconf tests work... yes
checking for 64-bit OS... yes
checking for Python version >= 2.5 but not 3.x... configure: error: Python 2.5 or higher (but not Python 3.x) is required.
gmake[1]: *** [GNUmakefile:74: ../build/../../src/../3rdp/clang.freebsd.amd64.release/mozjs/lib/libmozjs185-1.0.a] Error 1
gmake[1]: Leaving directory '/var/tmp/gitlab_runner/builds/TkL89aUh/4/main/sbbs/3rdp/build'
gmake: *** [/var/tmp/gitlab_runner/builds/TkL89aUh/4/main/sbbs/src/sbbs3/../build/Common.gmake:521: js] Error 2
ERROR: Job failed: exit status 1