Synchronet now requires the libarchive development package (e.g. libarchive-dev on Debian-based Linux distros, libarchive.org for more info) to build successfully.

  • Rob Swindell's avatar
    Allow SAFECAT to work on uchar arrays · 1111fb24
    Rob Swindell authored
    Caught by CID 331001
    
    The use of SAFECAT() with a typecast to a pointer is not going to work as expected. This change broke line-based telnet-gateway functionality (unconfirmed, but pretty obvious).
    1111fb24