Synchronet now requires the libarchive development package (e.g. libarchive-dev on Debian-based Linux distros, libarchive.org for more info) to build successfully.

Commit 9260b561 authored by runemaster's avatar runemaster

Fix bug in last commit.

parent 8b699538
......@@ -26,9 +26,14 @@ else {
error("You can't read messages in this sub!");
}
if(msg_area.sub[sub].can_post) {
template.can_post=true;
if(sub=='mail' && user.alias!='Guest') {
template.can_post=true;
}
else {
if(msg_area.sub[sub].can_post) {
template.can_post=true;
}
}
template.idx=msgbase.get_msg_index(false,m);
if(sub=='mail' && template.idx.to!=user.number)
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment