Synchronet now requires the libarchive development package (e.g. libarchive-dev on Debian-based Linux distros, libarchive.org for more info) to build successfully.

Commit 9e22b06f authored by Deucе's avatar Deucе 👌🏾

Improve error message

parent 7b3303e7
......@@ -708,7 +708,7 @@ function parse_command(line)
var ret='';
if (line.search(/^{([0-9]+)}$/) !== 0)
throw new Error('invalid line, aborting');
throw new Error('invalid string literal ('+line+'), aborting');
line=line.replace(/^{([0-9]+)}$/, "$1");
client.socket.send("+ Give me more of that good stuff\r\n");
var len = parseInt(line);
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment