Synchronet now requires the libarchive development package (e.g. libarchive-dev on Debian-based Linux distros, libarchive.org for more info) to build successfully.

Commit b26a1b71 authored by deuce's avatar deuce

Hack around windows.h insanity.

parent cbfed770
......@@ -47,6 +47,9 @@
/***************/
#if defined(_WIN32) /* Windows */
#define NOCRYPT /* Stop windows.h from loading wincrypt.h */
/* Is windows.h REALLY necessary?!?! */
#define WIN32_LEAN_AND_MEAN
#include <io.h>
#include <share.h>
#include <windows.h>
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment